1с рмк поддержка ут

Оплата картами в 1с 8.3 эквайрингработа в рмк для 1с ут 11.3 продажа, возврат, отложенный чек и сверка по отчетам

Оплата картами в 1С 8.3 (Эквайринг)

работа в РМК для 1С УТ 11.3 Продажа, возврат, отложенный чек и сверка по отчетам

Дисконтная карта, бонусная система, оплата сертификатом для 1С Розница и Управление торговлей

Прием оплаты от клиента в кассу в 1С Управление торговлей 11. Касса в 1С УТ 11

Оплата банковскими картами в 1С:УНФ

Настройка рабочего места кассира 1С Управление торговлей 11

Торговые представители в УТ 11

Настройка бонусной системы оплаты в 1С Розница 2.1

Возврат оплаты клиенту наличным способом в 1С Управление торговлей 11. Касса в 1С УТ 11

УТ 11 Как заводить безналичную оплату от клиента


DaTig
6 января 2019 в 17:59

В типовой конфигурации УТ 11 нет возможности в режиме РМК изменить цену на товар, хотя такая необходимость появляется довольно часто. Внеся небольшие изменения в конфигурацию, можно добиться нужной функциональности. Использовался релиз 1С УТ 11.4.5.135 на платформе 1С: Предприятие (8.3.13.1513).

Кто прежде работал с конфигурациями 1С Розница 2.2 и 1С УТ 10.3, столкнувшись с УТ 11 могут быть неприятно удивлены, обнаружив, что в режиме РМК нельзя изменять цену за продаваемый товар (услугу). В обозначенных выше конфигурациях есть дополнительные настройки пользователей, которые и отвечают за право менять цену в РМК. В УТ 11 такого нет. Все цены необходимо назначать через документ «Установка цен номенклатуры», откуда они и будут подставляться в РМК при продаже. На практике, по разным причинам, часто возникает необходимость оперативно в РМК изменить цену.

Для получения нужного результата, надо внести небольшие изменения в конфигурацию УТ 11. За РМК отвечает документ чекККМ и форма ФормаДокументаРМК.

image

Первым делом в свойствах колонки «Цена» убираем галочку с пункта «Только просмотр»

image

После этого надо внести изменения в код модуля: находим там процедуру

Процедура ДобавитьВКорзину

&НаКлиенте
Процедура ДобавитьВКорзину(ПараметрыТовара)
	
	Если ТолькоПросмотр Тогда
		Возврат;
	КонецЕсли;
	
	НовыеСтроки = Новый Массив;
	
	Если ЗапрашиватьКоличество Тогда
		
		ПараметрыФормы = Новый Структура("Склад, Номенклатура, Характеристика, ВидЦены, Упаковка, Цена, 
		|Дата, Валюта, РедактироватьЦену, РедактироватьВидЦены");
		
		ЗаполнитьЗначенияСвойств(ПараметрыФормы, ПараметрыТовара);
		
		ПараметрыФормы.Склад = Объект.Склад;
		ПараметрыФормы.Дата = Объект.Дата;
		ПараметрыФормы.Валюта = Объект.Валюта;
//{{MRG[ <-> ]
		ПараметрыФормы.РедактироватьЦену = Ложь;
//}}MRG[ <-> ]
//{{MRG[ <-> ]
//}}MRG[ <-> ]
		ПараметрыФормы.РедактироватьВидЦены = Ложь;
		ПараметрыФормы.ВидЦены = Объект.ВидЦены;
		
		Если ПараметрыТовара.ТипНоменклатуры = ПредопределенноеЗначение("Перечисление.ТипыНоменклатуры.Набор") Тогда
			ИмяФормыЗапросаКоличества = "Документ.ЧекККМ.Форма.ЗапросКоличестваНабор";
		Иначе
			ИмяФормыЗапросаКоличества = "Документ.ЧекККМ.Форма.ЗапросКоличества";
		КонецЕсли;
		
		ДополнительныеПараметры = Новый Структура;
		ДополнительныеПараметры.Вставить("НовыеСтроки", НовыеСтроки);
		ДополнительныеПараметры.Вставить("ПараметрыТовара", ПараметрыТовара);
		ОткрытьФорму(
			ИмяФормыЗапросаКоличества,
			ПараметрыФормы,
			ЭтотОбъект,
			УникальныйИдентификатор,,,
			Новый ОписаниеОповещения("ЗапросКоличестваЗавершение", ЭтотОбъект, ДополнительныеПараметры));
		
	Иначе
		
		Если ПараметрыТовара.ТипНоменклатуры = ПредопределенноеЗначение("Перечисление.ТипыНоменклатуры.Набор") Тогда
			
			ПараметрыКомплектующих = ПодборТоваровКлиентСервер.ПараметрыТовара();
			ЗаполнитьЗначенияСвойств(ПараметрыКомплектующих, ПараметрыТовара);
			ПараметрыКомплектующих.НоменклатураНабора   = ПараметрыТовара.Номенклатура;
			ПараметрыКомплектующих.ХарактеристикаНабора = ПараметрыТовара.Характеристика;
			ПараметрыКомплектующих.Вставить("ВариантКомплектацииНоменклатуры", Неопределено);
			
			ДополнительныеПараметры = Новый Структура;
			ДополнительныеПараметры.Вставить("Дата",    Объект.Дата);
			ДополнительныеПараметры.Вставить("Валюта",  Объект.Валюта);
			ДополнительныеПараметры.Вставить("ВидЦены", Объект.ВидЦены);
			ДополнительныеПараметры.Вставить("Цена",    ПараметрыТовара.Цена);
			ПодобранныеТовары = НаборыВызовСервера.Комплектующие(ПараметрыКомплектующих, ДополнительныеПараметры);
			
			Для Каждого ПодобранныйТовар Из ПодобранныеТовары Цикл
				НовыеСтроки.Добавить(ПодобранныйТовар);
			КонецЦикла;
			
		Иначе
			
			Если Не ЗначениеЗаполнено(ПараметрыТовара.Упаковка) Тогда
				ПараметрыТовара.Упаковка = ПодборТоваровВызовСервера.ПолучитьУпаковкуХранения(ПараметрыТовара.Номенклатура);	
			КонецЕсли;
			
			НовыеСтроки.Добавить(ПараметрыТовара);
			
		КонецЕсли;
		
		ПараметрыДанных = Новый Структура;
		ПараметрыДанных.Вставить("НовыеСтроки", НовыеСтроки);
		ПараметрыДанных.Вставить("ПараметрыТовара", ПараметрыТовара);
		
		ДобавитьВКорзинуФрагмент(ПараметрыДанных);
		
	КонецЕсли;
	
КонецПроцедуры

и меняем строку

ПараметрыФормы.РедактироватьЦену = Ложь;

на

ПараметрыФормы.РедактироватьЦену = Истина;

Чтобы сумма чека автоматически пересчитывалась при изменении цены необходимо в свойство «События» «При изменении» добавить процедуру:

image

Процедура ТоварыЦенаПриИзменеии

&НаКлиенте
Процедура ТоварыЦенаПриИзменении(Элемент)
	
	ТекущаяСтрока = Элементы.Товары.ТекущиеДанные;	
	СтруктураДействий = Новый Структура;
	ДобавитьВСтруктуруДействияПриИзмененииЦены(СтруктураДействий,Объект);
	ОбработкаТабличнойЧастиКлиент.ОбработатьСтрокуТЧ(ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения);
	
	ПересчитатьДокументНаКлиенте();
	
КонецПроцедуры

А в область

#Область ПриИзмененииРеквизитов

Функцию

ДобавитьВСтруктуруДействияПриИзмененииЦены

&НаКлиентеНаСервереБезКонтекста
Функция ДобавитьВСтруктуруДействияПриИзмененииЦены(СтруктураДействий,Объект)

	СтруктураДействий.Вставить("ПересчитатьСумму");	

КонецФункции

После проделанных манипуляций, поле «цена» в РМК УТ 11 становится доступной для изменения:

image

Файл обработки: redaktirovanie-tseny-v-rmk-ut-11-4.cfe

Тестировалось в программе: 1С:Управление торговлей 11.4.6, 11.4.8, 11.4.11, 11.4.12, 11.4.13, 11.4.14, 11.5.7 Работает только в ПРОФ версиях.        Как узнать версию программы?

Разработка скачивалась: Да

Закрытый программный код: Да (если на странице не указано обратное)

Работает только в операционной системе: Windows

Внимание! Для работы расширения в релизах отличных от 11.4.8 необходимо изменить режим совместимости расширения.

В типовой конфигурации УТ 11.4 нет возможности в режиме РМК изменить цену на товар, хотя в некоторых случаях такая возможность необходима. Данное расширение делает цены в РМК программы 1С УТ 11.4 доступными для редактирования.

После подключения (добавления) расширения и перезапуска программы Вы сможете вручную изменять цены в РМК программы 1С УТ 11.4.

Для добавления расширения перейдите в НСИ и администрирование — Печатные формы, отчеты и обработки — Расширения и добавьте наше расширение, после чего снимите галочку Безопасный режим и перезапустите текущий сеанс.

Расширение Редактирование цены в РМК для 1С:УТ 11.4 содержит открытый код

Расширение «Редактирование цены в РМК» для 1С:УТ 11.4

Дата создания страницы: 22.03.2019

Дата изменения страницы: 21.12.2021

Наша обработка помогла Вам?   Оставьте, пожалуйста, комментарий ниже.

1С:РМК — программа для автономной деятельности кассира на рабочем месте, с подключенным торговым оборудованием. Полностью соответствует законодательству о розничной торговле.

В течение 2021 года программу станет можно использовать как внешнее дополнительное рабочее место кассира для решений «1С:Касса», «1С:Управление нашей фирмой», «1С:Управление торговлей», «1С:Комплексная автоматизация», «1С:ERP Управление предприятием».

Преимущества:

  • современный и удобный интерфейс, адаптированный для мониторов разных размеров и с разным разрешением;
  • комфортная работа с сенсорными мониторами;
  • максимально просто подключается к типовым конфигурациям для автоматизации розничной торговли;
  • можно централизованно управлять парком подключенных РМК из центрального офиса торговой сети;
  • функционал 1С:РМК в перспективе разовьется до уровня самых популярных рабочих мест кассира, которые представлены на российском рынке.

Общие настройки рабочего места кассира:

  • формируется только электронная версия чека, можно распечатать бумажный чек по требованию покупателя;
  • максимально разрешенный процент скидки и точность округления;
  • шаблоны штрих-кода весового товара;
  • настройки интерфейса (заголовки, надписи, картинки и т. д.);
  • подключение к бонусному серверу.

К сожалению такой страницы большеужеещё нет на нашем ресурсе. Мы сожалеем об этом 😨
В качестве компенсации прослушайте, пожалуйста, тeматическую композицию Леонида Агутина.